Instagram Pages showing as hidden in Meta Workspaces

Incident Report for Smartly Status Page

Resolved

Our team has rolled out a fix and Instagram Pages will no longer auto hide/disconnect. Please follow these steps to make sure Instagram Pages are now correctly connected.

1. Head to "Media > Campaign Assets > Pages & Apps"
2. Connect your Instagram Page under "Instagram Accounts"
Posted May 22, 2025 - 11:46 UTC

Investigating

We are aware of Instagram accounts showing as hidden in Meta Workspaces at the moment and is actively investigating. We will provide updates once we know more.
Posted May 22, 2025 - 03:24 UTC
This incident affected: Platform Services (Facebook API) and Advertising (Campaign Workspaces).