Issues loading Google workspaces due to Dynamite Server Issues

Incident Report for Smartly Status Page

Resolved

This issue has been resolved.
Posted Feb 25, 2026 - 19:53 UTC

Investigating

We are currently experiencing slowness loading Google Workspace Blueprints.
Posted Feb 25, 2026 - 18:31 UTC
This incident affected: Advertising (Campaign Workspaces).