The error message ‘Your image couldn’t be downloaded’ was due to a temporary issue on Meta’s end. This has now been resolved, and you should be able to view your ad preview and proceed with publishing your ads.
If you have any further questions or need assistance, feel free to reach out to support. Have a great rest of your day!
Posted Apr 24, 2026 - 05:09 UTC
Update
We are currently investigating reports of a potential issue with ad previews and ad publishing, which is causing a subset of users to experience errors when previewing and publishing ads. We are contacting Meta and investigating the issue at the same time. All active ads should continue to deliver as expected. We apologize for any inconvenience and will provide another update as soon as we have more information.
Posted Apr 23, 2026 - 08:57 UTC
Investigating
We are currently investigating reports of a potential issue with ad previews and ad publishing, which is causing a subset of users to experience errors when previewing and publishing ads.
We are contacting Meta and investigating the issue at the same time. All active ads should continue to deliver as expected.
We apologize for any inconvenience and will provide another update as soon as we have more information.
Posted Apr 23, 2026 - 08:52 UTC
This incident affected: Advertising (Campaign Workspaces).