Multiplatform Review Page Not Loading

Incident Report for Smartly Status Page

Resolved

We confirm that all platform workspace review page are now operational. Thank you for your patience.
Posted Apr 01, 2026 - 16:15 UTC

Monitoring

Most platforms have since recovered except for Pinterest Workspace Review. We'll update once that has also recovered.
Posted Apr 01, 2026 - 15:14 UTC

Identified

We're currently aware and in the middle of fixing an issue affecting Workspaces Multiplatform Review Page from loading.
Posted Apr 01, 2026 - 14:14 UTC
This incident affected: Advertising (Campaign Workspaces).