Internal Error on Review Page for Snapchat

Incident Report for Smartly Status Page

Resolved

The issue causing an Internal Server Error on the Snapchat Review page and during publishing has been resolved. Our team has confirmed that services are operating normally and will continue to monitor the situation.

We apologize for any inconvenience and appreciate your patience.
Posted Jun 19, 2026 - 11:33 UTC

Investigating

We are currently experiencing degraded performance with Snapchat Review page and publishing causing an Internal Server Error to show up. Our team is currently working on resolving this issue. All your running ads should continue to deliver. We apologize for any inconvenience and will post another update as soon as this issue is resolved
Posted Jun 19, 2026 - 09:31 UTC
This incident affected: Platform Services (Snapchat API).