Meta Workspaces Review inaccessible

Incident Report for Smartly Status Page

Resolved

We’re happy to report that the Review page in Meta Workspaces is now functioning normally. We apologize for the disruption and sincerely appreciate your patience and understanding while our team worked to resolve the issue.
Posted Mar 13, 2026 - 09:26 UTC

Investigating

We're currently investigating reports of an issue with Meta Workspaces causing a subset of users to experience difficulties when attempting to access the Review page. All your running ads should continue to deliver. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Mar 13, 2026 - 08:14 UTC
This incident affected: Advertising (Campaign Workspaces).