Publishing or Editing Meta Ads on Smartly Fails with error: "The id of the object (post, page, etc) passed in is invalid"

Incident Report for Smartly Status Page

Resolved

Meta's engineers have fixed this issue. The team identified the issue stemmed from an internal experiment aimed at improving ad reliability/performance, but the change accidentally prevented certain accounts from creating ads using the dataset ID in the offline_conversion tracking_spec. You can now publish Meta ads again using pixels in the Offline Conversions Tracking.
Posted Mar 18, 2025 - 19:55 UTC

Monitoring

Meta's team has suggested a workaround: Remove the Offline Conversion Tracking pixels in the Ad tracking level and publish the ads. Thank you for patience as our teams worked on finding a solution for this issue!
Posted Mar 18, 2025 - 17:19 UTC

Investigating

Meta Support is aware of this API originated issue and is already looking into this. We're working with our Meta Engineering Partners to prioritize fixing this as well.

The identified possible workarounds are removing all UTM parameters or attempt to create the Ad with a different set-up (eg. Different Media, Post ID etc)
Posted Mar 14, 2025 - 10:20 UTC
This incident affected: Platform Services (Facebook API).