Facebook DSQ - Ad Creation Fail with "An unexpected error has occurred. Please retry your request later." *FIXED*

Incident Report for Smartly Status Page

Resolved

Investigating - Meta has confirmed there were issues with Ad Delivery and Creation around 18:00 - 24:00 CET and it has since been fixed (https://metastatus.com/ads-manager). Your campaign/adset/ad edits and creation should no longer see the error ""An unexpected error has occurred. Please retry your request later.". If you are still seeing errors - please contact Support Chat to start a new investigation.
Posted Aug 22, 2025 - 15:14 UTC

Update

Meta has confirmed there were issues with Ad Delivery and Creation around 18:00 - 24:00 CET and it has since been fixed (https://metastatus.com/ads-manager). Your campaign/adset/ad edits and creation should no longer see the error ""An unexpected error has occurred. Please retry your request later.". If you are still seeing errors - please contact Support Chat to start a new investigation.
Posted Aug 22, 2025 - 15:13 UTC

Investigating

When creating or edit campaigns META is returning and unexpected error for unknown reasons. We've escalated this to META.
Posted Aug 21, 2025 - 16:44 UTC
This incident affected: Platform Services (Facebook API) and Advertising (Campaign Assets).