We were writing to confirm that issues affecting Meta Workspaces should be working as per normal now. Please let Support know if you encounter any other issues. Thank you for your patience and understanding.
Posted Mar 12, 2025 - 01:06 UTC
Monitoring
We are seeing improvements and actively monitoring the situation to ensure a full recovery. Please retry any actions you were taking before the issue occurred.
Posted Mar 12, 2025 - 00:39 UTC
Investigating
We’re currently investigating reports of slowness with Meta Workspaces causing most users to experience unable to: sync changes to Meta Workspaces, change budgets in Reporting , Review and publish campaigns . All your running ads should continue to deliver.
Any urgent changes or checks can still be done directly on Meta Ads Manager.
We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Mar 12, 2025 - 00:15 UTC
This incident affected: Advertising (Campaign Workspaces).