This issue may be affecting only a limited number of impressions. We have confirmed that this issue is limited to the App, as the same Ad in another account functions correctly on mobile and desktop devices. To facilitate our investigation, we kindly request that you contact support to report the issue. This will enable us to gather as much relevant information as possible, such as the consumer’s Instagram account and the advertisement URL. Given the circumstances, it may be challenging to replicate the issue.
It is possible that this issue is related to Meta’s experiments with DPA, but we have not yet identified a definitive cause.
Posted Jun 17, 2026 - 17:10 UTC
Investigating
We are aware of reports that some served ads on Meta are displaying broken image placeholders (refresh icons) instead of actual images.
Our team is actively investigating the issue and is working with Meta to gather additional information and determine the scope and impact. We will provide further updates as soon as more details become available.
Posted Jun 17, 2026 - 11:12 UTC
This incident affects: Platform Services (Facebook API).